Hướng dẫn định tuyến IPv6 và OSPF trên Cisco ASA

cấu hình định tuyến IP

Cấu hình định tuyến IP với Cisco ASA

Định tuyến là hành động di chuyển thông tin qua mạng nội bộ từ nguồn đến đích. Trên đường đi, ít nhất một nút trung gian thường gặp phải. Định tuyến bao gồm hai hoạt động cơ bản: xác định đường dẫn định tuyến tối ưu và truyền các nhóm thông tin (thường được gọi là các gói) thông qua một mạng liên mạng.

Trong bối cảnh của quá trình định tuyến, sau này được gọi là chuyển mạch gói. Mặc dù chuyển mạch gói tương đối đơn giản, nhưng việc xác định đường dẫn có thể rất phức tạp.

Các giao thức Internet được hỗ trợ để định tuyến

ASA hỗ trợ một số giao thức Internet để định tuyến. Mỗi giao thức được mô tả ngắn gọn trong phần này.
• Giao thức định tuyến cổng nội bộ nâng cao (EIGRP)
EIGRP cung cấp khả năng tương thích và tương thích liền mạch với các bộ định tuyến IGRP. Một cơ chế phân phối lại tự động cho phép các tuyến IGRP được nhập vào IGRP nâng cao và ngược lại, do đó, có thể thêm IGRP nâng cao dần vào mạng IGRP hiện có.

• Mở đường dẫn ngắn nhất đầu tiên (OSPF)
Open Shortest Path First (OSPF) là một giao thức định tuyến được phát triển cho các mạng Internet Protocol (IP) bởi nhóm làm việc giao thức cổng vào (IGP) của Nhóm công tác kỹ thuật Internet (IETF). OSPF sử dụng thuật toán trạng thái kết nối để xây dựng và tính toán đường đi ngắn nhất đến tất cả các đích đã biết. Mỗi bộ định tuyến trong một vùng OSPF bao gồm một cơ sở dữ liệu trạng thái kết nối giống hệt nhau, đây là danh sách của mỗi giao diện có thể sử dụng bộ định tuyến và các hàng xóm có thể truy cập.

• Giao thức thông tin định tuyến
Giao thức thông tin định tuyến (RIP) là một giao thức vector khoảng cách sử dụng số lượng hop làm chỉ số của nó. RIP được sử dụng rộng rãi để định tuyến lưu lượng trong Internet toàn cầu và là một giao thức cổng vào (IGP), có nghĩa là nó thực hiện định tuyến trong một hệ thống tự trị duy nhất.

Thêm hoặc chỉnh sửa tuyến tĩnh

route if_name dest_ip mask gateway_ip
[distance]
Example:
hostname(config)# route outside 10.10.10.0 255.255.255.0 192.168.1.1 [1]
Examples

hostname(config)# route outside 10.10.10.0 255.255.255.0 192.168.1.1
hostname(config)# route outside 10.10.10.0 255.255.255.0 192.168.1.2
hostname(config)# route outside 10.10.10.0 255.255.255.0 192.168.1.3

Định cấu hình tuyến IPV6

ASA tự động định tuyến lưu lượng IPv6 giữa các máy chủ được kết nối trực tiếp nếu các giao diện mà máy chủ được gắn vào được kích hoạt cho IPv6 và các ACL IPv6 cho phép lưu lượng truy cập.
Để định cấu hình tuyến đường mặc định IPv6 và tuyến tĩnh, hãy thực hiện các bước sau:

Step 1

ipv6 route if_name ::/0 next_hop_ipv6_addr
Example:
hostname(config)# ipv6 route inside 7fff::0/32 3FFE:1100:0:CC00::1
Step 2

ipv6 route if_name destination
next_hop_ipv6_addr [admin_distance]
Example:
hostname(config)# ipv6 route inside 7fff::0/32 3FFE:1100:0:CC00::1 [110]

Để định cấu hình theo dõi tuyến đường tĩnh, hãy thực hiện các bước sau:

Bước 1

sla monitor sla_id
Thí dụ:
hostname (config) # sla monitor sla_id
Step 2

type echo protocol ipIcmpEcho target_ip
interface if_name
Example:
hostname(config-sla-monitor)# type echo protocol ipIcmpEcho target_ip interface if_name
Step 3

sla monitor schedule sla_id [life {forever
| seconds}] [start-time {hh:mm [:ss]
[month day | day month] | pending | now |
after hh:mm:ss}] [ageout seconds]
[recurring]

Example:
hostname(config)# sla monitor schedule sla_id [life {forever | seconds}] [start-time {hh:mm[:ss] [month day | day month] | pending | now | after hh:mm:ss}] [ageout seconds] [recurring]

Step 4

track track_id rtr sla_id reachability
Example:
hostname(config)# track track_id rtr sla_id reachability
Bước 5

Thực hiện một trong các thao tác sau để xác định tuyến tĩnh được cài đặt trong bảng định tuyến trong khi đối tượng được theo dõi có thể truy cập được.

Các tùy chọn này cho phép bạn theo dõi tuyến đường tĩnh hoặc tuyến đường mặc định thu được thông qua DHCP hoặc PPPOE.
route if_name dest_ip mask gateway_ip
[admin_distance] track track_id
Example:
hostname(config)# route if_name dest_ip mask gateway_ip [admin_distance] track track_id
Example:
hostname(config)# interface phy_if
hostname(config-if)# dhcp client route track track_id
hostname(config-if)# ip address dhcp setroute
hostname(config-if)# exit
Example:
hostname(config)# interface phy_if
hostname(config-if)# pppoe client route track track_id
hostname(config-if)# ip address pppoe setroute
hostname(config-if)# exit
Ví dụ cấu hình cho các tuyến tĩnh hoặc tuyến mặc định

Ví dụ sau đây cho thấy cách tạo một tuyến tĩnh gửi tất cả lưu lượng đến 10.1.1.0/24 đến router 10.1.2.45, được kết nối với giao diện bên trong, định nghĩa ba tuyến tĩnh chi phí bằng nhau để hướng lưu lượng truy cập đến ba cổng khác nhau trên giao diện bên ngoài và thêm tuyến đường mặc định cho lưu lượng truy cập đường hầm. Sau đó ASA phân phối lưu lượng giữa các cổng được chỉ định:

hostname(config)# route inside 10.1.1.0 255.255.255.0 10.1.2.45 1
hostname(config)# route outside 10.10.10.0 255.255.255.0 192.168.2.1
hostname(config)# route outside 10.10.10.0 255.255.255.0 192.168.2.2
hostname(config)# route outside 10.10.10.0 255.255.255.0 192.168.2.3
hostname(config)# route outside 0 0 192.168.2.4 tunneled

Cấu hình OSPF

OSPF là một giao thức định tuyến cổng vào nội bộ sử dụng các trạng thái liên kết chứ không phải các vectơ khoảng cách để chọn đường đi. OSPF tuyên truyền quảng cáo trạng thái kết nối thay vì định tuyến cập nhật bảng. Vì chỉ có các LSA được trao đổi thay vì toàn bộ các bảng định tuyến, các mạng OSPF hội tụ nhanh hơn các mạng RIP.

OSPF sử dụng thuật toán trạng thái kết nối để xây dựng và tính toán đường đi ngắn nhất đến tất cả các đích đã biết. Mỗi bộ định tuyến trong một vùng OSPF có chứa một cơ sở dữ liệu trạng thái kết nối giống hệt nhau, đây là danh sách của mỗi giao diện có thể sử dụng của bộ định tuyến và các hàng xóm có thể truy cập.

Ưu điểm của OSPF trên RIP bao gồm

• Cập nhật cơ sở dữ liệu trạng thái kết nối OSPF được gửi ít thường xuyên hơn bản cập nhật RIP và cơ sở dữ liệu trạng thái kết nối được cập nhật ngay lập tức, thay vì dần dần, vì thông tin cũ đã hết thời gian chờ.

• Các quyết định định tuyến được dựa trên chi phí, đó là một dấu hiệu của chi phí cần thiết để gửi các gói tin trên một giao diện nhất định. ASA tính toán chi phí của một giao diện dựa trên băng thông liên kết thay vì số bước nhảy đến đích. Chi phí có thể được cấu hình để xác định đường dẫn ưa thích.

Điểm bất lợi của các thuật toán đầu tiên của đường đi ngắn nhất là chúng đòi hỏi rất nhiều chu trình và bộ nhớ CPU.

ASA hỗ trợ các tính năng OSPF sau đây:
• Hỗ trợ các tuyến đường nội bộ, interarea và bên ngoài (Loại I và Loại II).
• Hỗ trợ liên kết ảo.
• Lũ lụt LSNG OSPF.
• Xác thực các gói OSPF (cả mật khẩu và xác thực MD5).
• Hỗ trợ cấu hình ASA như một bộ định tuyến được chỉ định hoặc một bộ định tuyến dự phòng được chỉ định. ASA cũng có thể được thiết lập như một ABR.
• Hỗ trợ cho các khu vực sơ khai và các khu vực không mập mạp.
• Bộ lọc ranh giới vùng 3 Bộ lọc LSA.

Cấu hình bật OSPF

Để kích hoạt OSPF, bạn cần phải tạo một quy trình định tuyến OSPF, chỉ định phạm vi địa chỉ IP liên quan đến quá trình định tuyến, sau đó gán các ID vùng được liên kết với dải địa chỉ IP đó.

Bạn có thể bật tối đa hai phiên bản OSPF. Mỗi quy trình OSPF đều có các khu vực và mạng liên quan riêng.
Để bật OSPF, hãy thực hiện các bước sau:

Step 1

router ospf process_id
Example:
hostname(config)# router ospf 2
Step 2

network ip_address mask area area_id
Example:
hostname(config)# router ospf 2
hostname(config-router)# network 10.0.0.0 255.0.0.0 area 0

Để phân phối lại các tuyến tĩnh, kết nối, RIP hoặc OSPF thành một quá trình OSPF, hãy thực hiện các bước sau:
Step 1

router ospf process_id
Example:
hostname(config)# router ospf 2
Step 2

redistribute connected
[[metric metric-value]
[metric-type {type-1 | type-2}]
[tag tag_value] [subnets] [route-map
map_name]

Example:
hostname(config)# redistribute connected 5 type-1 route-map-practice
redistribute static [metric metric-value]
[metric-type {type-1 | type-2}]
[tag tag_value] [subnets] [route-map
map_name

Example:
hostname(config)# redistribute static 5 type-1 route-map-practice
redistribute ospf pid [match {internal |
external [1 | 2] | nssa-external [1 | 2]}]
[metric metric-value]
[metric-type {type-1 | type-2}]
[tag tag_value] [subnets] [route-map
map_name]

Example:
hostname(config)# route-map 1-to-2 permit
hostname(config-route-map)# match metric 1
hostname(config-route-map)# set metric 5
hostname(config-route-map)# set metric-type type-1
hostname(config-route-map)# router ospf 2
hostname(config-router)# redistribute ospf 1 route-map 1-to-2
redistribute rip [metric metric-value]
[metric-type {type-1 | type-2}]
[tag tag_value] [subnets] [route-map
map_name]

Example:
hostname(config)# redistribute rip 5
hostname(config-route-map)# match metric 1
hostname(config-route-map)# set metric 5
hostname(config-route-map)# set metric-type type-1
hostname(config-router)# redistribute ospf 1 route-map 1-to-2
redistribute eigrp as-num
[metric metric-value]
[metric-type {type-1 | type-2}]
[tag tag_value] [subnets] [route-map
map_name]

Example:
hostname(config)# redistribute eigrp 2
hostname(config-route-map)# match metric 1
hostname(config-route-map)# set metric 5
hostname(config-route-map)# set metric-type type-1
hostname(config-router)# redistribute ospf 1 route-map 1-to-2

Cấu hình tuyến đường giữa các vùng OSPF

Tính năng này làm cho một tuyến đường tóm tắt duy nhất được quảng cáo đến các khu vực khác bằng bộ định tuyến ranh giới khu vực. Trong OSPF, một bộ định tuyến ranh giới khu vực quảng cáo mạng trong một khu vực vào một khu vực khác.

Nếu số mạng trong khu vực được gán theo cách sao cho chúng liền kề nhau, bạn có thể định cấu hình bộ định tuyến ranh giới khu vực để quảng cáo tuyến tóm tắt bao gồm tất cả các mạng riêng lẻ trong khu vực nằm trong phạm vi được chỉ định.

Để xác định phạm vi địa chỉ cho tóm tắt tuyến đường, hãy thực hiện các bước sau:

Step 1

router ospf process_id
Example:
hostname(config)# router ospf 1
Step 2

area area-id range ip-address mask
[advertise | not-advertise]

Example:
hostname(config)# router ospf 1
hostname(config-router)# area 17 range
12.1.0.0 255.255.0.0

Cấu hình các tham số giao diện OSPF

Để cấu hình các tham số giao diện OSPF, thực hiện các bước sau:
Step 1
router ospf process_id
Example:
hostname(config)# router ospf 2
Step 2

network ip_address mask area area_id

Example:
hostname(config)# router ospf 2

hostname(config-router)# network 10.0.0.0 255.0.0.0 area 0
Step 3

hostname(config)# interface interface_name

Example:
hostname(config)# interface my_interface
Step 4

ospf authentication [message-digest | null]

Example:
hostname(config-interface)# ospf authentication message-digest
ospf authentication-key key

Example:
hostname(config-interface)# ospf authentication-key cisco
ospf cost cost

Example:
hostname(config-interface)# ospf cost 20
ospf dead-interval seconds

Example:
hostname(config-interface)# ospf dead-interval 40

ospf hello-interval seconds

Example:
hostname(config-interface)# ospf hello-interval 10
ospf message-digest-key key_id md5 key

Example:
hostname(config-interface)# ospf message-digest-key 1 md5 cisco
ospf retransmit-interval seconds

Example:
hostname(config-interface)# ospf retransmit-interval seconds
ospf transmit-delay seconds

Example:
hostname(config-interface)# ospf
transmit-delay 5
ospf network point-to-point non-broadcast

Example:
hostname(config-interface)# ospf network point-to-point non-broadcast
Khởi động lại quy trình OSPF
clear ospf pid {process | redistribution |
counters [neighbor [neighbor-interface]
[neighbor-id]]}
Example:
hostname(config)# clear ospf

Ví dụ cấu hình cho OSPF

Ví dụ sau đây cho thấy cách kích hoạt và cấu hình OSPF với các quy trình tùy chọn khác nhau:

Step 1 Để bật OSPF, hãy nhập các lệnh sau:

hostname(config)# router ospf 2
hostname(config-router)# network 10.0.0.0 255.0.0.0 area 0

Step 2 (Optional) Để phân phối lại các tuyến từ một quá trình OSPF đến một quy trình OSPF khác, hãy nhập các lệnh sau đây:

hostname(config)# route-map 1-to-2 permit
hostname(config-route-map)# match metric 1
hostname(config-route-map)# set metric 5
hostname(config-route-map)# set metric-type type-1
hostname(config-route-map)# router ospf 2
hostname(config-router)# redistribute ospf 1 route-map 1-to-2

Step 3 (Optional) Để cấu hình các tham số giao diện OSPF, hãy nhập các lệnh sau:

hostname(config)# router ospf 2
hostname(config-router)# network 10.0.0.0 255.0.0.0 area 0
hostname(config-router)# interface inside
hostname(config-interface)# ospf cost 20
hostname(config-interface)# ospf retransmit-interval 15
hostname(config-interface)# ospf transmit-delay 10
hostname(config-interface)# ospf priority 20
hostname(config-interface)# ospf hello-interval 10
hostname(config-interface)# ospf dead-interval 40
hostname(config-interface)# ospf authentication-key cisco
hostname(config-interface)# ospf message-digest-key 1 md5 cisco
hostname(config-interface)# ospf authentication message-digest

Step 4 (Optional) Để cấu hình các tham số vùng OSPF, nhập các lệnh sau:

hostname(config)# router ospf 2
hostname(config-router)# area 0 authentication
hostname(config-router)# area 0 authentication message-digest
hostname(config-router)# area 17 stub
hostname(config-router)# area 17 default-cost 20

Step 5 (Optional) Để định cấu hình bộ tính giờ tuyến đường và hiển thị thông báo lên và xuống nhật ký, hãy nhập các lệnh sau:

hostname(config-router)# timers spf 10 120
hostname(config-router)# log-adj-changes [detail]

Step 6 Để khởi động lại quá trình OSPF, hãy nhập các lệnh sau:

hostname(config)# clear ospf pid {process | redistribution | counters
[neighbor [neighbor-interface] [neighbor-id]]}

Step 7 (Optional) Để hiển thị các thiết lập cấu hình OSPF hiện tại, nhập lệnh show ospf.
Sau đây là đầu ra mẫu từ lệnh show ospf:

hostname(config)# show ospf
Routing Process “ospf 2” with ID 10.1.89.2 and Domain ID 0.0.0.2

Giám sát OSPF

Bạn có thể hiển thị các thống kê cụ thể như nội dung của bảng định tuyến IP, bộ đệm và cơ sở dữ liệu. Bạn cũng có thể sử dụng thông tin được cung cấp để xác định việc sử dụng tài nguyên và giải quyết các vấn đề về mạng. Bạn cũng có thể hiển thị thông tin về khả năng hiển thị của nút và khám phá đường dẫn định tuyến mà gói thiết bị của bạn đang thực hiện thông qua mạng.

Để theo dõi hoặc hiển thị các thống kê định tuyến OSPF khác nhau, hãy nhập một trong các lệnh sau:

show ospf [process-id [area-id]]
show ospf border-routers
show ospf [process-id [area-id]] database
show ospf flood-list if-name
show ospf interface [if_name]
show ospf neighbor [interface-name]
[neighbor-id] [detail]
show ospf request-list neighbor if_name
show ospf retransmission-list neighbor
if_name
show ospf [process-id] summary-address
show ospf [process-id] virtual-links

Mọi thắc về nội dung trong bài viết xin vui lòng liên hệ với chúng tôi để được tư vấn hỗ trợ, giải đáp các thắc mắc tốt nhất.

Hướng dẫn định tuyến IPv6 và OSPF trên Cisco ASA
5 (100%) 3 đánh giá

Trả lời

Email của bạn sẽ không được hiển thị công khai. Các trường bắt buộc được đánh dấu *