Hướng dẫn cấu hình EIGRP trên Cisco ASA 5500 Series sử dụng CLI

Cấu hình EIGRP với ASA 5500 sử dụng CLI

Chi tiết cấu hình EIGRP trên Cisco ASA 5500 Series sử dụng CLI

Trong loạt bài Series trước CiscoData đã hướng dẫn các bạn chi tiết cấu hình các chức năng của tường lửa Cisco ASA và trong bài tin này chúng tôi sẽ tiếp tục hướng dẫn các bạn cấu hình chức năng EIGRP trên Cisco ASA5500.

Tìm hiểu đôi nét về chức năng EIGRP

EIGRP là một phiên bản nâng cao của IGRP do Cisco phát triển. Không giống như IGRP và RIP, EIGRP không gửi các bản cập nhật tuyến định kỳ. Bản cập nhật EIGRP chỉ được gửi khi cấu trúc liên kết mạng thay đổi.

Các khả năng chính phân biệt EIGRP với các giao thức định tuyến khác bao gồm hội tụ nhanh, hỗ trợ mặt nạ mạng con có độ dài thay đổi, hỗ trợ cập nhật từng phần và hỗ trợ nhiều giao thức lớp mạng.

Một Router chạy EIGRP lưu tất cả các bảng định tuyến lân cận để nó có thể nhanh chóng thích ứng với các tuyến đường thay thế. Nếu không có tuyến đường thích hợp tồn tại, EIGRP truy vấn các nước láng giềng của nó để khám phá một tuyến đường thay thế.

Các truy vấn này lan truyền cho đến khi tìm thấy tuyến đường thay thế. Sự hỗ trợ của nó cho mặt nạ mạng con thay đổi chiều dài cho phép các tuyến đường được tự động tóm tắt trên một ranh giới số mạng. Ngoài ra, EIGRP có thể được cấu hình để tóm tắt trên bất kỳ ranh giới bit nào ở bất kỳ giao diện nào. EIGRP không cập nhật định kỳ.

Thay vào đó, nó sẽ gửi các cập nhật một phần chỉ khi số liệu cho một tuyến đường thay đổi. Tuyên truyền các bản cập nhật từng phần được tự động giới hạn để chỉ những bộ định tuyến cần thông tin mới được cập nhật. Là kết quả của hai khả năng này, EIGRP tiêu thụ băng thông ít hơn đáng kể so với IGRP.

Giao thức EIGRP sử dụng bốn công nghệ thuật toán chính, bốn công nghệ chính, bao gồm khám phá / khôi phục lân cận, Giao thức truyền tải đáng tin cậy (RTP) và DUAL, điều quan trọng đối với tính toán tuyến đường. DUAL lưu tất cả các tuyến đường đến một điểm đến trong bảng tô pô, không chỉ là tuyến đường có chi phí thấp nhất.

Tuyến đường ít tốn kém nhất được đưa vào bảng định tuyến. Các tuyến khác vẫn còn trong bảng tôpô. Nếu tuyến đường chính không thành công, tuyến đường khác sẽ được chọn từ những người kế thừa khả thi. Người kế thừa là một bộ định tuyến lân cận được sử dụng để chuyển tiếp gói có đường dẫn ít tốn kém nhất đến đích. Tính toán tính khả thi đảm bảo rằng đường dẫn không phải là một phần của vòng lặp định tuyến.

Các bước cấu hình EIGRP chi tiết

Cấu hình bật EIGRP

Bạn chỉ có thể kích hoạt một quy trình cấu hình định tuyến EIGRP trên ASA và để bật EIGRP, hãy thực hiện các bước sau:
Step 1

router eigrp as-num
Example:
hostname(config)# router eigrp 2

Step 2

network ip-addr [mask]
Example:
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0 255.0.0.0

Kích hoạt định tuyến EIGRP Stub

Bạn có thể kích hoạt và cấu hình ASA như một bộ định tuyến EIGRP. Định tuyến sơ đồ làm giảm bộ nhớ và các yêu cầu xử lý trên ASA. Là một bộ định tuyến sơ khai, ASA không cần phải duy trì một bảng định tuyến EIGRP hoàn chỉnh vì nó chuyển tiếp tất cả lưu lượng truy cập không tới một router phân phối. Nói chung, bộ định tuyến phân phối không cần gửi bất kỳ thứ gì nhiều hơn một tuyến đường mặc định tới bộ định tuyến sơ khai.

Chỉ các tuyến được chỉ định được truyền từ bộ định tuyến sơ khai đến bộ định tuyến phân phối. Là một bộ định tuyến sơ khai, ASA phản hồi tất cả các truy vấn cho tóm tắt, các tuyến được kết nối, các tuyến tĩnh phân phối lại, các tuyến bên ngoài và các tuyến nội bộ với thông báo “không thể truy cập”. Khi ASA được cấu hình như một sơ khai, nó sẽ gửi một gói thông tin ngang hàng đặc biệt tới tất cả các router lân cận để báo cáo trạng thái của nó như là một bộ định tuyến sơ khai.

Bất kỳ người hàng xóm nào nhận được gói tin thông báo trạng thái gốc sẽ không truy vấn bộ định tuyến sơ khai cho bất kỳ tuyến đường nào và một bộ định tuyến có một nhánh ngang hàng sẽ không truy vấn đồng đẳng đó. Bộ định tuyến sơ khai phụ thuộc vào bộ định tuyến phân phối để gửi các bản cập nhật chính xác cho tất cả các đồng nghiệp.

Để kích hoạt ASA như một quá trình định tuyến sơ khai EIGRP, hãy thực hiện các bước sau:
Chi tiết các bước cấu hình
Step 1

router eigrp as-num
Example:
hostname(config)# router eigrp 2

Step 2

network ip-addr [mask]
Example:
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0 255.0.0.0

Step 3

eigrp stub {receive-only | [connected]
[redistributed] [static] [summary]}
Example:
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0
255.0.0.0
hostname(config-router)# eigrp stub
{receive-only | [connected]
[redistributed] [static] [summary]}

Cấu hình giao diện cho EIGRP

Nếu bạn có một giao diện mà bạn không muốn tham gia vào định tuyến EIGRP, nhưng nó được gắn vào một mạng mà bạn muốn được quảng cáo, bạn có thể cấu hình một lệnh mạng bao gồm mạng mà giao diện được đính kèm và sử dụng thụ động -interface lệnh để ngăn chặn giao diện đó gửi hoặc nhận cập nhật EIGRP.
Chi tiết các bước cấu hình giao diện cho EIGRP
Step 1

router eigrp as-num
Example:
hostname(config)# router eigrp 2

Step 2

hostname(config-router)# network ip-addr
[mask]
Example:
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0 255.0.0.0

Step 3
no default-information {in | out | WORD}
Example:
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0
255.0.0.0

hostname(config-router)# no
default-information {in | out | WORD}
authentication mode eigrp as-num md5
Example:
hostname(config)# authentication mode
eigrp 2 md5

delay value
Example:
hostname(config-if)# delay 200

hello-interval eigrp as-num seconds
Example:
hostname(config)# hello-interval eigrp 2
60

hold-time eigrp as-num seconds
Example:
hostname(config)# hold-time eigrp 2 60

Cấu hình giao diện thụ động EIGRP

Bạn có thể cấu hình một hoặc nhiều giao diện như giao diện thụ động. Trong EIGRP, một giao diện thụ động không gửi hoặc nhận các cập nhật định tuyến.
Để cấu hình EIGRP các giao diện thụ động, hãy thực hiện các bước sau:
Step 1

router eigrp as-num
Example:
hostname(config)# router eigrp 2
Step 2

hostname(config-router)# network ip-addr
[mask]
Example:
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0 255.0.0.0
Step 3

passive-interface {default | if-name}
Example:
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0
255.0.0.0
hostname(config-router)# passive-interface
{default}.

Cấu hình các địa chỉ tổng hợp tóm tắt trên giao diện

Step 1

interface phy_if
Example:
hostname(config)# interface phy_if

Step 2

summary-address eigrp as-num address mask
[distance]
Example:
hostname(config-if)# summary-address eigrp
2 address mask [20]

Bật xác thực EIGRP trên giao diện

Xác thực tuyến đường EIGRP cung cấp xác thực MD5 cập nhật định tuyến từ giao thức định tuyến EIGRP. Thông báo khóa MD5 trong mỗi gói EIGRP ngăn cản việc đưa ra các thông báo định tuyến trái phép hoặc sai từ các nguồn không được chấp thuận.
Xác thực tuyến đường EIGRP được định cấu hình trên cơ sở cho mỗi giao diện. Tất cả các hàng xóm EIGRP trên các giao diện được cấu hình xác thực EIGRP phải được cấu hình với cùng một chế độ xác thực và khóa cho các adjacencies được thiết lập.

Chi tiết các bước thực hiện
Step 1

router eigrp as-num
Example:
hostname(config)# router eigrp 2

Step 2

network ip-addr [mask]
Example:
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0 255.0.0.0

Step 3

interface phy_if
Example:
hostname(config)# interface phy_if

Step 4

authentication mode eigrp as-num md5
Example:
hostname(config)# authentication mode
eigrp 2 md5

Step 5

authentication key eigrp as-num key key-id
key-id
Example:
hostname(config)# authentication key eigrp
2 cisco key-id 200

Định nghĩa một hàng xóm EIGRP

Các gói tin EIGRP hello được gửi dưới dạng các gói multicast. Nếu một người hàng xóm EIGRP nằm trên một mạng không phát sóng, chẳng hạn như một đường hầm, bạn phải xác định thủ công hàng xóm đó. Khi bạn định nghĩa thủ công một hàng xóm EIGRP, các gói chào sẽ được gửi đến hàng xóm đó dưới dạng các thông báo unicast.
Để xác định thủ công hàng xóm EIGRP, hãy thực hiện các bước sau:
Step 1

router eigrp as-num
Example:
hostname(config)# router eigrp 2
Step 2

default-metric bandwidth delay reliability
loading mtu
Example:
hostname(config)# router eigrp 2
hostname(config-router)# default-metric
bandwidth delay reliability loading mtu
Step 3
redistribute connected [metric bandwidth
delay reliability loading mtu] [route-map
map_name]
Example:
hostname(config-router): redistribute
connected [metric bandwidth delay
reliability loading mtu] [route-map
map_name]

redistribute static [metric bandwidth
delay reliability loading mtu] [route-map
map_name]
Example:
hostname(config-router): redistribute
static [metric bandwidth delay reliability
loading mtu] [route-map map_name]

redistribute ospf pid [match {internal |
external [1 | 2] | nssa-external [1 | 2]}]
[metric bandwidth delay reliability
loading mtu] [route-map map_name]
Example:
hostname(config-router): redistribute ospf
pid [match {internal | external [1 | 2] |
nssa-external [1 | 2]}] [metric bandwidth
delay reliability loading mtu] [route-map
map_name]

redistribute rip [metric bandwidth delay
reliability load mtu] [route-map map_name]
Example:
(config-router): redistribute rip [metric
bandwidth delay reliability load mtu]
[route-map map_name]

Lọc mạng trong EIGRP

Step 1

router eigrp as-num
Example:
hostname(config)# router eigrp 2

Step 2

hostname(config-router)# network ip-addr
[mask]
Example:
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0 255.0.0.0

Step 3
distribute-list acl out [connected | ospf
| rip | static | interface if_name]
Example:
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0
255.0.0.0
hostname(config-router): distribute-list
acl out [connected]
distribute-list acl in [interface if_name]
Example:
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0
255.0.0.0
hostname(config-router): distribute-list
acl in [interface interface1]

Cấu hình thông tin mặc định trong EIGRP

Step 1

router eigrp as-num
Example:
hostname(config)# router eigrp 2
Step 2

hostname(config-router)# network ip-addr
[mask]
Example:
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0 255.0.0.0

Step 3

no default-information {in | out | WORD}
Example:
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0
255.0.0.0
hostname(config-router)# no
default-information {in | out | WORD}

Giám sát EIGRP

Bạn có thể sử dụng các lệnh sau để theo dõi quá trình định tuyến EIGRP. Để biết ví dụ và mô tả về đầu ra lệnh, xem tham chiếu lệnh. Ngoài ra, bạn có thể tắt tính năng ghi nhật ký các thông báo thay đổi hàng xóm và thông báo cảnh báo lân cận.

Giám sát định tuyến EIGRP

show eigrp [as-number] events [{start end}
| type]
show eigrp [as-number] neighbors [detail |
static] [if-name]
show eigrp [as-number] interfaces [if-name]
[detail]
show eigrp [as-number] topology [ip-addr
[mask] | active | all-links | pending |
summary | zero-successors]
show eigrp [as-number] traffic
router-id

Tắt thông báo ghi nhật ký EIGRP

no eigrp log-neighbor-changes
no eigrp log-neighbor-warnings

Ví dụ cấu hình cho EIGRP

Ví dụ sau đây cho thấy cách kích hoạt và cấu hình EIGRP với các quy trình tùy chọn khác nhau:

Bước 1 Để kích hoạt EIGRP, nhập các lệnh sau:
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0 255.0.0.0
Bước 2 Để cấu hình giao diện gửi hoặc nhận tin nhắn định tuyến EIGRP, hãy nhập lệnh sau:
hostname(config-router)# passive-interface {default}
Bước 3 Để xác định một hàng xóm EIGRP, nhập lệnh sau:
hostname(config-router)# neighbor 10.0.0.0 interface interface1
Bước 4 Để cấu hình các giao diện và mạng tham gia định tuyến EIGRP, hãy nhập lệnh sau:
ostname(config-router)# network 10.0.0.0 255.0.0.0
Bước 5 Để thay đổi giá trị độ trễ giao diện được sử dụng trong tính toán khoảng cách EIGRP, hãy nhập các lệnh sau:
hostname(config-router)# exit
hostname(config)# interface phy_if
hostname(config-if)# delay 200
Mọi thắc mắc hãy liên lạc với chúng tôi theo các Hotline trên Website để được tư vấn và hỗ trợ tốt nhất.

Hướng dẫn cấu hình EIGRP trên Cisco ASA 5500 Series sử dụng CLI
5 (100%) 2 đánh giá

Trả lời

Email của bạn sẽ không được hiển thị công khai. Các trường bắt buộc được đánh dấu *